Browse Source

Cleanup Python 2.7 support

OpenStack is dropping the py2.7 support in ussuri cycle.

Make a few cleanups:
- Remove python 2.7 stanza from setup.py
- Add python-requires to setup.cfg so that pypi and pip know
  about support Python version
- Remove ancient sections from setup.cfg
- Remove version_info setting from conf.py, openstackdocstheme does this
  automatically nowadays.

Change-Id: I5b9c159752c932f874015f20822862c70562c2bd
tags/5.3.0
Andreas Jaeger 3 months ago
parent
commit
f01a0f336c
3 changed files with 1 additions and 25 deletions
  1. +0
    -13
      doc/source/conf.py
  2. +1
    -3
      setup.cfg
  3. +0
    -9
      setup.py

+ 0
- 13
doc/source/conf.py View File

@@ -12,8 +12,6 @@
# All configuration values have a default; values that are commented out
# serve to show the default.

import pbr.version

# -- General configuration ----------------------------------------------------

# If your documentation needs a minimal Sphinx version, state it here.
@@ -55,17 +53,6 @@ master_doc = 'index'
project = u'OpenStack Command Line Client'
copyright = u'2012-2013 OpenStack Foundation'

# The version info for the project you're documenting, acts as replacement for
# |version| and |release|, also used in various other places throughout the
# built documents.
#
version_info = pbr.version.VersionInfo('python-openstackclient')
#
# The short X.Y version.
version = version_info.version_string()
# The full version, including alpha/beta/rc tags.
release = version_info.release_string()

# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
#language = None


+ 1
- 3
setup.cfg View File

@@ -6,6 +6,7 @@ description-file =
author = OpenStack
author-email = openstack-discuss@lists.openstack.org
home-page = https://docs.openstack.org/python-openstackclient/latest/
python-requires = >=3.6
classifier =
Environment :: OpenStack
Intended Audience :: Information Technology
@@ -715,9 +716,6 @@ openstack.volume.v3 =
volume_transfer_request_list = openstackclient.volume.v2.volume_transfer_request:ListTransferRequest
volume_transfer_request_show = openstackclient.volume.v2.volume_transfer_request:ShowTransferRequest

[upload_sphinx]
upload-dir = doc/build/html

[extract_messages]
keywords = _ gettext ngettext l_ lazy_gettext
mapping_file = babel.cfg


+ 0
- 9
setup.py View File

@@ -13,17 +13,8 @@
# See the License for the specific language governing permissions and
# limitations under the License.

# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools

# In python < 2.7.4, a lazy loading of package `pbr` will break
# setuptools if some other modules registered functions in `atexit`.
# solution from: http://bugs.python.org/issue15881#msg170215
try:
import multiprocessing # noqa
except ImportError:
pass

setuptools.setup(
setup_requires=['pbr>=2.0.0'],
pbr=True)

Loading…
Cancel
Save