Browse Source

[ussuri][goal] Drop python 2.7 support and testing

OpenStack is dropping the py2.7 support in ussuri cycle.

python-searchlightsclient is ready with python 3 and ok to drop the
python 2.7 support.

Complete discussion & schedule can be found in
- http://lists.openstack.org/pipermail/openstack-discuss/2019-October/010142.html
- https://etherpad.openstack.org/p/drop-python2-support

Ussuri Communtiy-wide goal:
https://governance.openstack.org/tc/goals/selected/ussuri/drop-py27.html

Change-Id: I37810f2e78523388a70cad0034f8d4d9e73e218b
changes/85/699085/3 2.0.0
Ghanshyam Mann 2 years ago
parent
commit
d307e8e6ed
  1. 1
      .zuul.yaml
  2. 1
      README.rst
  3. 3
      doc/requirements.txt
  4. 6
      releasenotes/notes/drop-py-2-7-5ef11499fe79e1ca.yaml
  5. 2
      setup.cfg
  6. 5
      tox.ini

1
.zuul.yaml

@ -1,6 +1,5 @@
- project:
templates:
- openstack-python-jobs
- openstack-python3-ussuri-jobs
- openstack-cover-jobs
- publish-openstack-docs-pti

1
README.rst

@ -148,6 +148,5 @@ Testing
There are multiple test targets that can be run to validate the code.
* tox -e pep8 - style guidelines enforcement
* tox -e py27 - traditional unit testing with python 2.7
* tox -e py36 - traditional unit testing with python 3.6
* tox -e py37 - traditional unit testing with python 3.7

3
doc/requirements.txt

@ -4,5 +4,4 @@
openstackdocstheme>=1.30.0 # Apache-2.0
sphinxcontrib-svg2pdfconverter>=0.1.0 # BSD
sphinx>=1.8.0,<2.0.0;python_version=='2.7' # BSD
sphinx>=1.8.0,!=2.1.0;python_version>='3.4' # BSD
sphinx>=1.8.0,!=2.1.0 # BSD

6
releasenotes/notes/drop-py-2-7-5ef11499fe79e1ca.yaml

@ -0,0 +1,6 @@
---
upgrade:
- |
Python 2.7 support has been dropped. Last release of python-searchlightclient
to support python 2.7 is OpenStack Train. The minimum version of Python now
supported is Python 3.6.

2
setup.cfg

@ -13,8 +13,6 @@ classifier =
License :: OSI Approved :: Apache Software License
Operating System :: POSIX :: Linux
Programming Language :: Python
Programming Language :: Python :: 2
Programming Language :: Python :: 2.7
Programming Language :: Python :: 3
Programming Language :: Python :: 3.6
Programming Language :: Python :: 3.7

5
tox.ini

@ -1,7 +1,8 @@
[tox]
envlist = pypy,py27,py37,pep8
minversion = 2.0
envlist = pypy,py37,pep8
minversion = 3.1.1
skipsdist = True
ignore_basepython_conflict = True
[testenv]
basepython = python3

Loading…
Cancel
Save