Browse Source

Fix requirements

Change-Id: Iadaf460c1d6068a106cd1c292c47205af3f71dab
tags/4.0.0^0
Q.hongtao 5 months ago
committed by Eyal
parent
commit
102acafefe
3 changed files with 15 additions and 16 deletions
  1. +7
    -7
      lower-constraints.txt
  2. +3
    -3
      requirements.txt
  3. +5
    -6
      test-requirements.txt

+ 7
- 7
lower-constraints.txt View File

@@ -1,8 +1,8 @@
appdirs==1.3.0
Babel==2.3.4
Babel==2.5.3
cliff==2.8.0
cmd2==0.8.0
coverage==4.0
coverage==4.5.1
debtcollector==1.2.0
decorator==3.4.0
deprecation==1.0
@@ -29,15 +29,15 @@ os-service-types==1.2.0
osc-lib==1.8.0
oslo.i18n==3.15.3
oslo.utils==3.33.0
oslotest==3.2.0
pbr==2.0.0
oslotest==3.3.0
pbr==3.1.1
pep8==1.5.7
prettytable==0.7.2
pyflakes==0.8.1
pyparsing==2.1.0
pyperclip==1.5.27
python-mimeparse==1.6.0
python-subunit==1.0.0
python-subunit==1.2.0
pytz==2013.6
PyYAML==3.12
requests==2.14.2
@@ -46,8 +46,8 @@ simplejson==3.5.1
six==1.10.0
stevedore==1.20.0
testrepository==0.0.18
testscenarios==0.4
testtools==2.2.0
testscenarios==0.5.0
testtools==2.3.0
traceback2==1.4.0
unittest2==1.1.0
wrapt==1.7.0


+ 3
- 3
requirements.txt View File

@@ -2,12 +2,12 @@
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.

pbr!=2.1.0,>=2.0.0 # Apache-2.0
Babel!=2.4.0,>=2.3.4 # BSD
pbr>=3.1.1 # Apache-2.0
Babel>=2.5.3 # BSD
cliff!=2.9.0,>=2.8.0 # Apache-2.0
osc-lib>=1.8.0 # Apache-2.0
oslo.utils>=3.33.0 # Apache-2.0
keystoneauth1>=3.4.0 # Apache-2.0
iso8601>=0.1.11 # MIT
networkx>=2.3;python_version>='3.4' # BSD
pydot>=1.4.1 # BSD
pydot>=1.4.1 # BSD

+ 5
- 6
test-requirements.txt View File

@@ -3,11 +3,10 @@
# process, which may cause wedges in the gate later.

hacking>=1.1.0 # Apache-2.0

coverage!=4.4,>=4.0 # Apache-2.0
python-subunit>=1.0.0 # Apache-2.0/BSD
oslotest>=3.2.0 # Apache-2.0
coverage>=4.5.1 # Apache-2.0
python-subunit>=1.2.0 # Apache-2.0/BSD
oslotest>=3.3.0 # Apache-2.0
testrepository>=0.0.18 # Apache-2.0/BSD
testscenarios>=0.4 # Apache-2.0/BSD
testtools>=2.2.0 # MIT
testscenarios>=0.5.0 # Apache-2.0/BSD
testtools>=2.3.0 # MIT
mock>=2.0.0 # BSD

Loading…
Cancel
Save