Browse Source

Cap oslo.db==6.0.0 for python <='3.5'

stackviz on stable/rocky is failing as it try to install the
latest requirements like oslo.db>=4.24.0

:stderr: oslo.db requires Python '>=3.6' but the running Python is 3.5.2

https://zuul.opendev.org/t/openstack/build/67edcd21a0144bd7a3e0a28294bd5874

Change-Id: I1c65b90ee4579c0e58d9c01a1244760dc74b82b3
changes/63/767063/5
Ghanshyam Mann 7 months ago
committed by Ghanshyam
parent
commit
3bb7bc77b7
  1. 3
      requirements.txt

3
requirements.txt

@ -1,5 +1,6 @@
python-subunit>=0.0.18
testtools>=0.9.30
testrepository>=0.0.18
subunit2sql>=0.8.0
oslo.db>=6.0.0;python_version>='3.6'
oslo.db==6.0.0;python_version<='3.5'
six
Loading…
Cancel
Save