Browse Source

drop anyjson requirement

Anyjson 0.3.3 is 9 years old project and is not installable on Python 3:

INFO:kolla.common.utils.tacker-base:Collecting anyjson>=0.3.3
INFO:kolla.common.utils.tacker-base:  Downloading anyjson-0.3.3.tar.gz (8.3 kB)
INFO:kolla.common.utils.tacker-base:ESC[91m    ERROR: Command errored out with exit status 1:
INFO:kolla.common.utils.tacker-base:     command: /var/lib/kolla/venv/bin/python3 -c 'import io, os, sys, setuptools, tokenize; sys.argv[0] = '"'"'/tmp/pip-install-zkeekfya/anyjson_956fe77196244503b52f1d5b9cacb75f/setup.py'"'"'; __file__='"'"'/tmp/pip-install-zkeekfya/anyjson_956fe77196244503b52f1d5b9cacb75f/setup.py'"'"';f = getattr(tokenize, '"'"'open'"'"', open)(__file__) if os.path.exists(__file__) else io.StringIO('"'"'from setuptools import setup; setup()'"'"');code = f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' egg_info --egg-base /tmp/pip-pip-egg-info-6n_kkxqa
INFO:kolla.common.utils.tacker-base:         cwd: /tmp/pip-install-zkeekfya/anyjson_956fe77196244503b52f1d5b9cacb75f/
INFO:kolla.common.utils.tacker-base:    Complete output (1 lines):
INFO:kolla.common.utils.tacker-base:    error in anyjson setup command: use_2to3 is invalid.
INFO:kolla.common.utils.tacker-base:    ----------------------------------------

And use of anyjson was dropped over 5 years ago:

commit aaeda502bb
Author: gong yong sheng <gong.yongsheng@99cloud.net>
Date:   Tue Jun 7 13:48:39 2016 +0800

    Use oslo serialization jsonutils

    Change-Id: I081697d987fc7c2bcd4ae73b97aedc058c57a84f

Change-Id: Ic4ceea9461a4d7e2e7afb3d7df93e530f7cd1ac3
changes/77/814777/1
Marcin Juszkiewicz 7 months ago
parent
commit
8c69dda51f
  1. 1
      lower-constraints.txt
  2. 1
      requirements.txt

1
lower-constraints.txt

@ -1,7 +1,6 @@
alabaster==0.7.10
alembic==0.9.6
amqp==2.4.0
anyjson==0.3.3
appdirs==1.4.3
asn1crypto==0.24.0
bcrypt==3.1.4

1
requirements.txt

@ -7,7 +7,6 @@ Paste>=2.0.2 # MIT
PasteDeploy>=1.5.0 # MIT
Routes>=2.3.1 # MIT
amqp>=2.4.0
anyjson>=0.3.3 # BSD
eventlet!=0.18.3,!=0.20.1,>=0.18.2 # MIT
requests>=2.25.1 # Apache-2.0
jsonschema>=3.2.0 # MIT

Loading…
Cancel
Save