Browse Source

Cleanup py27 support

This repo is now testing only with Python 3, so let's make
a few cleanups:
- Remove python 2.7 stanza from setup.py
- Add requires on python >= 3.6 to setup.cfg so that pypi and pip
  know about the requirement
- Remove obsolete sections from setup.cfg
- Update classifiers
- Update requirements, no need for python_version anymore
- Use newer openstackdocstheme version

Change-Id: Ic7696a6ba0fc213b59edf87cf9ef2a804ebca94f
changes/31/719531/2
Andreas Jaeger 1 year ago
parent
commit
3cfa46f1d2
  1. 3
      lower-constraints.txt
  2. 7
      requirements.txt
  3. 13
      setup.cfg
  4. 9
      setup.py
  5. 5
      test-requirements.txt

3
lower-constraints.txt

@ -19,7 +19,6 @@ eventlet==0.20.0
extras==1.0.0
fasteners==0.7.0
fixtures==3.0.0
futures==3.0.0;python_version=='2.7' or python_version=='2.6'
gitdb==0.6.4
GitPython==1.0.1
idna==2.6
@ -43,7 +42,7 @@ msgpack-python==0.4.0
munch==2.1.0
netaddr==0.7.18
netifaces==0.10.4
openstackdocstheme==1.20.0
openstackdocstheme==1.31.2
openstacksdk==0.11.2
os-client-config==1.28.0
os-service-types==1.2.0

7
requirements.txt

@ -4,8 +4,7 @@
pbr!=2.1.0,>=2.0.0 # Apache-2.0
Babel!=2.4.0,>=2.3.4 # BSD
GitPython>=1.0.1;python_version>='3.0' # BSD License (3 clause)
GitPython>=1.0.1,<2.1.12;python_version<'3.0' # BSD License (3 clause)
GitPython>=1.0.1 # BSD License (3 clause)
eventlet!=0.20.1,>=0.20.0 # MIT
python-heatclient>=1.10.0 # Apache-2.0
oslo.config>=5.2.0 # Apache-2.0
@ -13,8 +12,7 @@ oslo.log>=3.36.0 # Apache-2.0
oslo.rootwrap>=5.8.0 # Apache-2.0
oslo.utils>=3.33.0 # Apache-2.0
python-glanceclient>=2.8.0 # Apache-2.0
python-ironicclient!=2.5.2,!=2.7.1,!=3.0.0,>=2.3.0,<4.0.0;python_version=='2.7' # Apache-2.0
python-ironicclient!=2.5.2,!=2.7.1,!=3.0.0,>=2.3.0;python_version>='3.6' # Apache-2.0
python-ironicclient!=2.5.2,!=2.7.1,!=3.0.0,>=2.3.0 # Apache-2.0
six>=1.10.0 # MIT
mistral-lib>=0.3.0 # Apache-2.0
oslo.concurrency>=3.26.0 # Apache-2.0
@ -30,7 +28,6 @@ python-zaqarclient>=1.0.0 # Apache-2.0
python-keystoneclient>=3.8.0 # Apache-2.0
keystoneauth1>=3.4.0 # Apache-2.0
tenacity>=4.4.0 # Apache-2.0
futures>=3.0.0;python_version=='2.7' or python_version=='2.6' # BSD
metalsmith>=0.13.0 # Apache-2.0
jsonschema>=2.6.0 # MIT
requests>=2.18.0,!=2.20.0 # Apache-2.0

13
setup.cfg

@ -6,6 +6,7 @@ description-file =
author = OpenStack
author-email = openstack-discuss@lists.openstack.org
home-page = https://docs.openstack.org/tripleo-common/latest/
python-requires = >=3.6
classifier =
Environment :: OpenStack
Intended Audience :: Information Technology
@ -13,8 +14,8 @@ classifier =
License :: OSI Approved :: Apache Software License
Operating System :: POSIX :: Linux
Programming Language :: Python
Programming Language :: Python :: 2
Programming Language :: Python :: 2.7
Programming Language :: Python :: Implementation :: CPython
Programming Language :: Python :: 3 :: Only
Programming Language :: Python :: 3
Programming Language :: Python :: 3.6
Programming Language :: Python :: 3.7
@ -45,14 +46,6 @@ data_files =
share/ansible/roles/ = roles/*
share/ansible/plugins/ = ansible_plugins/*
[build_sphinx]
source-dir = doc/source
build-dir = doc/build
all_files = 1
[upload_sphinx]
upload-dir = doc/build/html
[compile_catalog]
directory = tripleo_common/locale
domain = tripleo-common

9
setup.py

@ -13,17 +13,8 @@
# See the License for the specific language governing permissions and
# limitations under the License.
# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools
# In python < 2.7.4, a lazy loading of package `pbr` will break
# setuptools if some other modules registered functions in `atexit`.
# solution from: http://bugs.python.org/issue15881#msg170215
try:
import multiprocessing # noqa
except ImportError:
pass
setuptools.setup(
setup_requires=['pbr>=2.0.0'],
pbr=True)

5
test-requirements.txt

@ -2,13 +2,12 @@
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
openstackdocstheme>=1.20.0 # Apache-2.0
openstackdocstheme>=1.31.2 # Apache-2.0
coverage!=4.4,>=4.0 # Apache-2.0
docutils>=0.11 # OSI-Approved Open Source, Public Domain
python-subunit>=1.0.0 # Apache-2.0/BSD
sphinx>=1.8.0,<2.0.0;python_version=='2.7' # BSD
sphinx>=1.8.0,!=2.1.0;python_version>='3.4' # BSD
sphinx>=1.8.0,!=2.1.0 # BSD
oslotest>=3.2.0 # Apache-2.0
stestr>=2.0.0 # Apache-2.0
testscenarios>=0.4 # Apache-2.0/BSD

Loading…
Cancel
Save