Browse Source

Stop barbican servics in unupgraded controllers

This change makes barbican services on unupgrade controller nodes get
stopped, because all services in the unupgrade controllers should be
stopped before we start the upgraded controller[1].

[1] 8529ce60da

Change-Id: I7031064b752450bacbb7775c0e357b98210a8929
(cherry picked from commit 6f140b93be)
(cherry picked from commit c996c85cae)
(cherry picked from commit 34c96db0e8)
changes/15/780815/1
Takashi Kajinami 8 months ago
committed by Jesse Pretorius (odyssey4me)
parent
commit
5be4f8f315
1 changed files with 15 additions and 0 deletions
  1. +15
    -0
      deployment/barbican/barbican-api-container-puppet.yaml

+ 15
- 0
deployment/barbican/barbican-api-container-puppet.yaml View File

@ -809,3 +809,18 @@ outputs:
- null
metadata_settings:
get_attr: [ApacheServiceBase, role_data, metadata_settings]
external_upgrade_tasks:
- when:
- step|int == 1
tags:
- never
- system_upgrade_transfer_data
- system_upgrade_stop_services
block:
- name: Stop barbican api container
import_role:
name: tripleo_container_stop
vars:
tripleo_containers_to_stop:
- barbican_api
tripleo_delegate_to: "{{ groups['barbican_api'] | default([]) }}"

Loading…
Cancel
Save