Browse Source

Use newer flake8 to run on ubuntu-focal Zuul machines

flake8 3.5.0  fails on ubuntu-focal zuul machines running python3.8
with the following error:
AttributeError: 'FlakesChecker' object has no attribute 'CONSTANT'

The update removes the version constraint to use newer flake8.  This
also ignores new warnings/errors, which should be addressed in a
future update to remove the ignores.

Change-Id: I16dc579f7ee803881c42ff6048ddd2f6bb0c553b
Partial-Bug: 1895054
Signed-off-by: Don Penney <don.penney@windriver.com>
changes/19/750819/1
Don Penney 9 months ago
parent
commit
fcae730d65
1 changed files with 3 additions and 2 deletions
  1. +3
    -2
      tox.ini

+ 3
- 2
tox.ini View File

@ -55,7 +55,7 @@ commands =
basepython = python3
usedevelop = False
deps =
flake8<3.6.0
flake8
description =
Run style checks
commands =
@ -65,8 +65,9 @@ commands =
[flake8]
show-source = True
exclude = .venv,.git,.tox,dist,doc,*lib/python*,*egg,build,release-tag-*
# W504 line break after binary operator
# H102 Apache License format
ignore = H102
ignore = W504,H102
[testenv:venv]
commands = {posargs}


Loading…
Cancel
Save