Browse Source

Lock platformdirs to version 2.4.0 to retain python 2.7 support

Platformdirs was upgraded to 2.4.1 from 2.4.0 over the holidays,
and this breaks our build that requires python 2.7 compatibility.
We'll stay with 2.4.0 which has worked for StarlingX for some time,
rather than reverting to 2.0.2 which was the last with official
python 2.7 support.

Closes-Bug: 1956054
Signed-off-by: Scott Little <scott.little@windriver.com>
Change-Id: I303429a744f4addf639f1ab88f03a06b52bc7144
changes/15/823215/3
Scott Little 5 months ago
parent
commit
7bde482bcb
  1. 4
      toCOPY/builder-constraints.txt

4
toCOPY/builder-constraints.txt

@ -1,3 +1,5 @@
more-itertools===5.0.0;python_version=='2.7' # Last version with official 2.7 support
pyparsing===2.4.7
filelock===3.4.0 # Last version with official support was 3.2.1, but 3.4.0 is known to work
filelock===3.4.0 # Last version with official py2.7 support was 3.2.1, but 3.4.0 is known to work
platformdirs===2.4.0 # Last version with official py2.7 support was 2.0.2, but 2.4.0 is known to work

Loading…
Cancel
Save