Browse Source

Drop ansible-2.6 and add ansible-2.9 for zuul-executors

Zuul has EOL'd ansible 2.6 and added ansible 2.9 support. Update our
playbooks to support that too.

Depends-On: https://review.opendev.org/724362
Change-Id: Ibaaabcf56a43ee4d323ca0a9ca98ce48d1873d90
Signed-off-by: Paul Belanger <pabelanger@redhat.com>
changes/40/702940/5
Paul Belanger 2 years ago
parent
commit
6030e20dc8
  1. 1
      .yamllint
  2. 12
      ansible/group_vars/zuul-executor.yaml

1
.yamllint

@ -1,3 +1,4 @@
---
extends: default
ignore: |

12
ansible/group_vars/zuul-executor.yaml

@ -94,12 +94,6 @@ ssh_key_private_content: |
ssh_key_private_dest: "{{ ssh_user_home }}/.ssh/nodepool_id_rsa"
zuul_executor_ansible:
- ansible_pip_name:
- ansible>=2.5,<2.6
- ara
ansible_pip_virtualenv_python: python3
ansible_pip_virtualenv: /opt/venv/ansible-2.5
ansible_pip_virtualenv_symlink: /opt/venv/zuul-ansible/2.5
- ansible_pip_name:
- ansible>=2.6,<2.7
- ara
@ -118,3 +112,9 @@ zuul_executor_ansible:
ansible_pip_virtualenv_python: python3
ansible_pip_virtualenv: /opt/venv/ansible-2.8
ansible_pip_virtualenv_symlink: /opt/venv/zuul-ansible/2.8
- ansible_pip_name:
- ansible>=2.9,<2.10
- ara
ansible_pip_virtualenv_python: python3
ansible_pip_virtualenv: /opt/venv/ansible-2.9
ansible_pip_virtualenv_symlink: /opt/venv/zuul-ansible/2.9

Loading…
Cancel
Save