Fuel plugin that enables to configure multiple Cinder backend support for Kaminario K2 All-Flash Array
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
OpenDev Sysadmins 5b7ac6e01c OpenDev Migration Patch 2 months ago
deployment_scripts/puppet Update fuel plugin repo Latest documentation changes 2 years ago
doc/plugin guide Update fuel plugin repo with latest Documents 2 years ago
repositories Initial Commit 2 years ago
specs Update fuel plugin repo with developer specs Document 2 years ago
.gitreview OpenDev Migration Patch 2 months ago
LICENSE Initial Commit 2 years ago
README.md Update fuel plugin repo for Kaminario 2 years ago
components.yaml Update fuel plugin repo with new UI changes 2 years ago
deployment_tasks.yaml Update fuel plugin repo with new UI changes 2 years ago
environment_config.yaml Update fuel plugin repo Latest documentation changes 2 years ago
metadata.yaml Update fuel plugin repo with latest metadata file 2 years ago
pre_build_hook Initial Commit 2 years ago
volumes.yaml Initial Commit 2 years ago

README.md

Cinder Kaminario plugin for Fuel

Overview

The plugin configures Kaminario backend for Cinder using multibackend feature.

The plugin support Kaminario K2 All-Flash arrays.

This repo contains all necessary files to build Cinder Kaminario Fuel plugin.

Requirements

Requirement Version/Comment
Mirantis Openstack compatibility 9.0
Kaminario K2 All-Flash array is reachable via one of the Mirantis OpenStack networks

How to build plugin:

  • Install fuel plugin builder (fpb)
  • Clone plugin repo

    # git clone https://github.com/openstack/fuel-plugin-cinder-kaminario.git
    
  • Build fuel plugin

    # cd fuel-plugin-cinder-kaminario/
    # fpb --build .
    
  • Install the plugin

    # fuel plugins --install cinder_kaminario-1.0-1.0.0-1.noarch.rpm
    
  • Verify that the plugin is installed correctly

    # fuel plugins
    
    id name version package_version
    1 cinder_kaminario-1.0-1.0.0-1.noarch.rpm 1.0.0 4.0.0