Manual sync with global requirements

shade, oaktreemodel and grpc are not in global-requirements, so this has
to be done by hand / with care. We need to remove python-*client from
shade before we can put it in the global-requirements, otherwise the
client lib versions will cause epic amounts of pain. So until we do that
we really can't apply for official status or directly follow
requirements. However, the intent is to follow them, so this will just
have to be something we keep up with by hand a bit.

Change-Id: Ie9fd8f121686f84b32f50371b24a247f86421b26
changes/58/395258/1
Monty Taylor 6 years ago
parent ffe27633d0
commit 15b519cc41
No known key found for this signature in database
GPG Key ID: 7BAE94BC7141A594

@ -2,7 +2,7 @@
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
pbr>=1.6
pbr>=1.6 # Apache-2.0
oaktreemodel
shade>=1.12.0
grpcio

@ -25,5 +25,5 @@ except ImportError:
pass
setuptools.setup(
setup_requires=['pbr'],
setup_requires=['pbr>=1.8'],
pbr=True)

@ -2,13 +2,13 @@
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
hacking<0.13,>=0.12.0
hacking<0.13,>=0.12.0 # Apache-2.0
coverage>=3.6
discover
python-subunit>=0.0.18
sphinx!=1.2.0,!=1.3b1,<1.3,>=1.1.2
coverage>=4.0 # Apache-2.0
discover # BSD
python-subunit>=0.0.18 # Apache-2.0/BSD
sphinx!=1.3b1,<1.4,>=1.2.1 # BSD
oslotest>=1.10.0 # Apache-2.0
testrepository>=0.0.18
testscenarios>=0.4
testtools>=1.4.0
testrepository>=0.0.18 # Apache-2.0/BSD
testscenarios>=0.4 # Apache-2.0/BSD
testtools>=1.4.0 # MIT

Loading…
Cancel
Save