Browse Source

Pin r10k to version 2.6.4

r10k version 3.0.0 and later require a newer version of the cri gem,
which only work with ruby >= 2.3. This does not work on CentOS 7,
where we have an earlier version.

Change-Id: I99958dd82bb95b8f3d7a6a2b0c86fd2c1f21c802
Javier Pena 6 months ago
parent
commit
4f8e95eccf
1 changed files with 1 additions and 1 deletions
  1. 1
    1
      run_tests.sh

+ 1
- 1
run_tests.sh View File

@@ -256,7 +256,7 @@ if [ "${INSTALL_FROM_SOURCE}" = true ]; then
256 256
   export GEM_BIN_DIR=/tmp/packstackgems/bin/
257 257
   export PUPPETFILE_DIR=/usr/share/openstack-puppet/modules
258 258
   export GEM_HOME=/tmp/packstackgems
259
-  $SUDO gem install r10k --no-ri --no-rdoc
259
+  $SUDO gem install r10k -v 2.6.4 --no-ri --no-rdoc
260 260
   # make sure there is no puppet module pre-installed
261 261
   $SUDO rm -rf "${PUPPETFILE_DIR:?}/"*
262 262
   install_modules

Loading…
Cancel
Save