Browse Source

Merge "Update test-requirements ansible version"

Zuul 8 months ago
parent
commit
54e633d25e
2 changed files with 3 additions and 3 deletions
  1. 2
    2
      test-requirements.txt
  2. 1
    1
      tox.ini

+ 2
- 2
test-requirements.txt View File

@@ -3,9 +3,9 @@
3 3
 # process, which may cause wedges in the gate later.
4 4
 flake8
5 5
 
6
-# We need to pin Ansible to <2.4 until Zuul supports it, otherwise ansible-lint
6
+# We need to pin Ansible to <2.6 until Zuul supports it, otherwise ansible-lint
7 7
 # picks the latest version which is not known to work yet.
8
-ansible<2.4
8
+ansible>=2.5.1,<2.6
9 9
 ansible-lint
10 10
 bashate>=0.2
11 11
 zuul-sphinx>=0.1.1

+ 1
- 1
tox.ini View File

@@ -38,7 +38,7 @@ passenv =
38 38
 deps =
39 39
   # Zuul is required to supply the zuul ansible modules for ansible-lint
40 40
   -egit+https://git.openstack.org/openstack-infra/zuul#egg=zuul
41
-  ansible<2.4.0
41
+  ansible>=2.5.1,<2.6
42 42
   ansible-lint
43 43
   hacking>=0.10,<0.11
44 44
   bashate>=0.2

Loading…
Cancel
Save