Remove remaining traces of Suse

It's been deprecated, time for removal.

Change-Id: I84c441f54c5793fe94b50810cda25f9eacee8c7e
changes/41/861541/3
Erik Berg 4 months ago
parent 0329463d77
commit eb5fab25a3

@ -1,12 +1,11 @@
gcc
git
libffi-devel [platform:redhat platform:suse]
libffi-devel [platform:redhat]
libffi-dev [platform:dpkg]
libopenssl-devel [platform:suse]
libselinux-utils [platform:redhat]
openssl-devel [platform:redhat]
libssl-dev [platform:dpkg]
lsb-release [platform:suse platform:dpkg]
lsb-release [platform:dpkg]
# NOTE(rpittau): lsb-release is not maintained anymore for centos 9 stream
redhat-lsb [platform:fedora platform:centos-8 platform:rhel-8]
make

@ -1,19 +0,0 @@
---
sgabios_dir: /usr/share/sgabios/
libvirt_service_name: libvirtd
required_packages:
- gcc-c++
- qemu-tools
- qemu-kvm
- qemu-x86
- qemu-sgabios
- libvirt
- libvirt-client
- libvirt-daemon
- libxslt-devel
- libxml2-devel
- pkg-config
- libvirt-devel
- qemu-ovmf-x86_64
- ebtables
- dnsmasq

@ -1,46 +0,0 @@
---
init_dest_dir: /usr/lib/systemd/system/
ipxe_dir: /usr/share/ipxe
ipxe_full_binary: ipxe.lkrn
ipxe_efi_binary: ipxe-x86_64.efi
ironic_rootwrap_dir: /usr/bin/
mysql_service_name: mysql
tftp_service_name: tftp
# FIXME(dtantsur): this may be incorrect, but I cannot figure out the correct
# path from just looking at various sources.
efi_distro: BOOT
grub_efi_binary: /usr/share/efi/x86_64/grub.efi
shim_efi_binary: /usr/share/efi/x86_64/shim.efi
required_packages:
- python-selinux
- mariadb-server
- dnsmasq
- python-devel
- python-iniparse
- libffi-devel
- libxslt-devel
- openssl-devel
- libxml2-devel
- ipxe-bootimgs
- qemu-ipxe
- parted
- ipmitool
- psmisc
- wget
- mkisofs
- kpartx
- qemu-tools
- policycoreutils-python
- dpkg
- iptables
- tar
- curl
- socat
- python-pip
- gcc
- python-PyMySQL
- apache2-utils
- syslinux
- grub2-x86_64-efi
- shim
- dosfstools

@ -15,13 +15,6 @@
set_fact:
grub_efi_source: /usr/lib/ironic/grub-efi
shim_efi_source: /usr/lib/ironic/shim-efi
when: ansible_os_family != 'Suse'
- name: "Set grub2 and shim paths for Suse"
set_fact:
grub_efi_source: "{{ grub_efi_binary }}"
shim_efi_source: "{{ shim_efi_binary }}"
when: ansible_os_family == 'Suse'
- name: "Create a temporary directory for mounting ESP"
tempfile:

@ -16,6 +16,6 @@ dib_host_required_packages:
- dosfstools
- e2fsprogs
- gdisk
- "squashfs{% if ansible_os_family != 'Suse' %}-tools{% endif %}"
- squashfs-tools
- xfsprogs
- "{% if 'debian' in dib_os_element or 'ubuntu' in dib_os_element %}debootstrap{% endif %}"

@ -1,14 +0,0 @@
---
init_dest_dir: /usr/lib/systemd/system/
mysql_service_name: mysql
required_packages:
- python-selinux
- mariadb
- policycoreutils-python
- python-devel
- python-MySQL-python
- python-iniparse
- libffi-devel
- libxslt-devel
- libopenssl-devel
- libxml2-devel

@ -263,5 +263,7 @@
- name: Enable keystone policy module
command: semodule -e keystone_policy
when: (ansible_os_family == 'RedHat' or ansible_os_family == 'Suse') and
ansible_selinux.status == 'enabled' and ansible_selinux.mode == "enforcing"
when:
- ansible_os_family == 'RedHat'
- ansible_selinux.status == 'enabled'
- ansible_selinux.mode == "enforcing"

@ -6,7 +6,6 @@ oslo.config>=5.2.0 # Apache-2.0
oslo.log>=3.36.0 # Apache-2.0
PyYAML>=3.12 # MIT
passlib>=1.7.2 # BSD
# TODO(dtantsur): remove pyOpenSSL when we no longer support Bionic and
# openSUSE updates its version to at least 18.0.0.
# TODO(dtantsur): remove pyOpenSSL when we no longer support Bionic
pyOpenSSL>=18.0.0 # Apache-2.0
setuptools!=48.0.0,!=49.0.0,>=39.0.1 # PSF/ZPL

@ -32,26 +32,6 @@ echo Detecting package manager
source /etc/os-release || source /usr/lib/os-release
case ${ID,,} in
*suse*)
OS_FAMILY="Suse"
INSTALLER_CMD="sudo -H -E zypper install -y --no-recommends"
CHECK_CMD="zypper search --match-exact --installed"
PKG_MAP=(
[python3]=python3
[python3-devel]=python3-devel
[python3-pip]=python3-pip
)
EXTRA_PKG_DEPS=()
# netstat moved to net-tools-deprecated in Leap 15
[[ ${VERSION%%.*} -lt 42 ]] && EXTRA_PKG_DEPS+=( net-tools-deprecated )
sudo zypper -n ref
# NOTE (cinerama): we can't install python without removing this package
# if it exists
if $(${CHECK_CMD} patterns-openSUSE-minimal_base-conflicts &> /dev/null); then
sudo -H zypper remove -y patterns-openSUSE-minimal_base-conflicts
fi
;;
ubuntu|debian)
OS_FAMILY="Debian"
export DEBIAN_FRONTEND=noninteractive
@ -151,11 +131,6 @@ fi
export PIP_OPTS="--upgrade-strategy only-if-needed"
if [[ $OS_FAMILY == "Suse" ]]; then
# https://storyboard.openstack.org/#!/story/2008591
${PIP} install -U setuptools
fi
echo "Installing bindep"
${PIP} install bindep

Loading…
Cancel
Save