Remove references to unsupported operating systems

All references to Gentoo, SUSE, Debian stretch and Centos-7  are removed.
Conditional tasks, ternary operators and variables are simplified where possible
OS specific variables files are generalised where possible

Change-Id: Ie84846f8590c3ae60afd671d973a4de3c644d526
changes/52/779752/1
Jonathan Rosser 2 years ago
parent c067e76792
commit b30094a654
  1. 2
      meta/main.yml
  2. 2
      tasks/tempest_install.yml

@ -23,7 +23,7 @@ galaxy_info:
platforms:
- name: Debian
versions:
- stretch
- buster
- name: Ubuntu
versions:
- bionic

@ -18,7 +18,7 @@
package:
name: "{{ tempest_package_list }}"
state: "{{ tempest_package_state }}"
update_cache: "{{ (ansible_facts['pkg_mgr'] in ['apt', 'zypper']) | ternary('yes', omit) }}"
update_cache: "{{ (ansible_facts['pkg_mgr'] == 'apt') | ternary('yes', omit) }}"
cache_valid_time: "{{ (ansible_facts['pkg_mgr'] == 'apt') | ternary(cache_timeout, omit) }}"
register: install_packages
until: install_packages is success

Loading…
Cancel
Save