Browse Source

Move pep8 dependencies from test-requirements to tox.ini

They're not needed there and are hard to constraint properly.

Change-Id: I2d9dee3dc2299656f305559145f7801b25ef30f3
changes/08/766908/4
Riccardo Pittau 4 months ago
parent
commit
1db6aef707
2 changed files with 6 additions and 6 deletions
  1. +0
    -6
      test-requirements.txt
  2. +6
    -0
      tox.ini

+ 0
- 6
test-requirements.txt View File

@ -1,10 +1,7 @@
# The order of packages is significant, because pip processes them in the order
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
hacking>=3.1.0,<4.0.0 # Apache-2.0
coverage!=4.4,>=4.0 # Apache-2.0
doc8>=0.6.0 # Apache-2.0
flake8-import-order>=0.17.1 # LGPLv3
fixtures>=3.0.0 # Apache-2.0/BSD
requests-mock>=1.2.0 # Apache-2.0
oslotest>=3.2.0 # Apache-2.0
@ -13,6 +10,3 @@ tempest>=17.1.0 # Apache-2.0
stestr>=1.0.0 # Apache-2.0
ddt>=1.0.1 # MIT
python-openstackclient>=3.12.0 # Apache-2.0
pycodestyle>=2.0.0,<2.7.0 # MIT
# Required for syntax highlighting check
Pygments>=2.2.0 # BSD

+ 6
- 0
tox.ini View File

@ -27,6 +27,12 @@ deps =
commands = sphinx-build -a -E -W -d releasenotes/build/doctrees -b html releasenotes/source releasenotes/build/html
[testenv:pep8]
deps =
hacking>=3.1.0,<4.0.0 # Apache-2.0
doc8>=0.6.0 # Apache-2.0
flake8-import-order>=0.17.1 # LGPLv3
pycodestyle>=2.0.0,<2.7.0 # MIT
Pygments>=2.2.0 # BSD
commands =
flake8 {posargs}
doc8 doc/source CONTRIBUTING.rst README.rst


Loading…
Cancel
Save