Browse Source

Cleanup py27 support

Make a few cleanups:
- Remove python 2.7 stanza from setup.py
- Add requires on python >= 3.6 to setup.cfg so that pypi and pip
  know about the requirement
- Remove obsolete sections from setup.cfg:
  * Wheel is not needed for python 3 only repo
- Update classifiers
- Update requirements, no need for python_version anymore

Change-Id: Ibc9c3d9448dc204e7877a00a9970e1673fd2951e
changes/63/717463/1
Andreas Jaeger 1 year ago
parent
commit
552ab25d19
3 changed files with 4 additions and 14 deletions
  1. +1
    -1
      doc/requirements.txt
  2. +3
    -4
      setup.cfg
  3. +0
    -9
      setup.py

+ 1
- 1
doc/requirements.txt View File

@ -3,5 +3,5 @@
# process, which may cause wedges in the gate later.
openstackdocstheme>=1.20.0 # Apache-2.0
reno>=2.5.0 # Apache-2.0
sphinx!=1.6.6,!=1.6.7,>=1.6.2;python_version>='3.4' # BSD
sphinx!=1.6.6,!=1.6.7,>=1.6.2 # BSD
sphinxcontrib-apidoc>=0.2.0 # BSD

+ 3
- 4
setup.cfg View File

@ -5,6 +5,7 @@ description-file = README.rst
author = OpenStack
author-email = openstack-discuss@lists.openstack.org
home-page = https://docs.openstack.org/python-ironicclient/latest/
python-requires = >=3.6
classifier =
Environment :: OpenStack
Intended Audience :: Information Technology
@ -12,6 +13,8 @@ classifier =
License :: OSI Approved :: Apache Software License
Operating System :: POSIX :: Linux
Programming Language :: Python
Programming Language :: Python :: Implementation :: CPython
Programming Language :: Python :: 3 :: Only
Programming Language :: Python :: 3
Programming Language :: Python :: 3.6
Programming Language :: Python :: 3.7
@ -115,10 +118,6 @@ openstack.baremetal.v1 =
baremetal_conductor_list = ironicclient.osc.v1.baremetal_conductor:ListBaremetalConductor
baremetal_conductor_show = ironicclient.osc.v1.baremetal_conductor:ShowBaremetalConductor
[wheel]
universal = 1
[extras]
cli =
python-openstackclient>=3.12.0 # Apache-2.0

+ 0
- 9
setup.py View File

@ -13,17 +13,8 @@
# See the License for the specific language governing permissions and
# limitations under the License.
# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools
# In python < 2.7.4, a lazy loading of package `pbr` will break
# setuptools if some other modules registered functions in `atexit`.
# solution from: http://bugs.python.org/issue15881#msg170215
try:
import multiprocessing # noqa
except ImportError:
pass
setuptools.setup(
setup_requires=['pbr>=2.0.0'],
pbr=True)

Loading…
Cancel
Save